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1.
Check  Your  PC

This section helps you to check your PC so that you can start working as soon as possible.

We will discuss the Win9x system.  You are supposed to know the basic operations of mouse, US keyboard, floppy and CDROM drives, and some simple features of Windows objects.

Refer to the official Microsoft Windows users’ handbook if necessary.

1.1
Registration Stickers

If your PC is maintained by ITSC, or your network card is provided by ITSC, check the two stickers of Reg. no. and Asset no.  All university computers on network should have these two stickers.  Notice that generally only registered computers receive constant supports from university technicians.  Contact ITSC for registration.

1.2
System Startup

Turn on your PC.  Select proper system boot option if a menu appears.  In general, Windows starts automatically without the menu.  To call the menu, press F8 immediately after system boot.
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When the Novell Client login window appears, type in your username and password to connect to the campus Novell network.  When the Microsoft login window appears, type in username and password only if you want to login an existing Microsoft network.  Notice, not every campus environment uses Microsoft network.  If you type nothing but still can start your computer, you do not login any server but only work on a standalone PC.   This PC may still be networked and you may browse the Internet normally.

For a new PC, the network wiring may not be activated yet.  Contact ITSC to follow.

For your own notebook PC, you need to provide your own PCMCIA network card to connect to the network.

1.2 Set Your Display Resolution

Right-click on the screen background and select “Properties” at the last option of the popped-up menu.  The “Display Properties” dialog window will appear.

Select the “Settings” tab.  Adjust the resolution in the “Desktop Area.”  Select “Font Size” and appropriate “Color Palette.”  The higher the pixel resolution is, the fewer the color bits become.  It depends on the available memory in the video card.
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Click “OK” after selection.

1.3 Create Shortcuts

For convenience, you can create shortcut icons on your desktop.  These icons have small arrows in their bottom-left corners to indicate their shortcut nature. Simply right-click on any file or folder icon, then select “Create Shortcut” to make the shortcut icon.  You can also pull the icon on your desktop.

1.5
Hard Disk Clean Up

Open Window Explorer, click on C: drive and check if the “Temp” directory exists.  Delete unnecessary files.  There are also “Temp” and “Temporary Internet Files” folders under “Windows” directory, which are managed by the system.  You may also clean some files within.  Do this often to save space.

1.6
Hard Disk Structural Scanning

Select “Programs > Accessories > System Tools > ScanDisk” in the desktop menu to start ScanDisk.  It fixes most hard disk bad sectors and file structure problems.

Select C: drive, “Standard” type of test, and “Automatically fix errors.”  Then press “Start.”  Wait until the process finishes.  Read the summary.  Do this often to check your hard disk.

If you shutdown the PC improperly, the system will go into a text-mode ScanDisk  procedure when it starts up again.  Make sure you shutdown the PC from proper Desktop control.

1.7 Virus Scanning

If you are using a PC passed from previous users, please take some time to scan all hard disks for viruses.  You should have installed a good virus scan program, like F-Secure AntiVirus, with updated virus data downloaded from company site.  ITSC offers a campus-wide license for you to use F-Secure AntiVirus, which can be downloaded from (also read the file fsinfo.html):

http://www.hkbu.edu.hk/~itsc/download/ setupex.exe
You will probably discover new viruses hidden in hard disks for over a year, even though virus shield is always on!  A virus shield can only protect your PC from the intrusion of recognized viruses from I/O devices or network sources.  That is why you need to keep your virus data latest.  Always activate the shield if available.

Schedule your virus scanning at least once a month.  Good anti-virus programs often provide scheduling functions.  Try to clean any virus you meet.  Move infected files to safe places if the files cannot be cleaned.  Report to technicians any new virus you find.

Remember to update your virus data.  It is a file which keeps record of new viruses.  For F-Secure AntiVirus, download it from:

http://www.hkbu.edu.hk/~itsc/download/ fsupdate.exe
Scan your hard disk at least once after you update your virus data.  Check for new data monthly.
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Software Installation Status

Besides going through the desktop “Programs” menu, you can check current software installation status by opening “Settings > Control Panel” window and then clicking “Add/Remove Programs” icon.  The window of “Add/Remove Programs Properties” appears with the “Install/Uninstall” tab shown.  Here you can install or uninstall local software which supports Windows registry system.

You can also change the software status coming from the Windows CDROM by checking the boxes in the “Windows Setup” tab.

2
Check Your Unix Account

This section briefly covers beginners’ topics of using your Unix account.
2.1 Connect to Your Workstation

Ask your account administrator about the hostname of your workstation, for example, “sccs4” is one of the computational workstations in the Scientific Computing Lab.

You can login a workstation by directly working in front of the workstation console or indirectly connecting from a remote terminal.

If you are using a remote X-Terminal (a graphical client network device), select the proper host in the login window and then type your username and password.  Beware of redundant space characters. Keep in mind that small letters are different from big letters.  Unix treats all these as different characters.

Most campus workstations have the same domain name “hkbu.edu.hk” while some workstations in specific labs have their own domain names, e.g. “sci.hkbu.edu.hk” for Scientific Computing Lab.  Students and staff should carry campus email account with domain suffix “hkbu.edu.hk”.

2.2
Graphical Login from PC (Exceed)
If you are using a PC, there are many ways to login your Unix account.  A simple method is to start Exceed to emulate a virtual X-Terminal.  Ask technicians if you want Exceed to be installed in your PC.

2.3
Terminal Login from PC (Telnet)

Another method is to start a terminal emulator like Telnet or NetTerm.  You can find Telnet applications in most local “windows” directories or shareware sites in the Internet.  If it is not there, install it from the Windows CDROM.  However, these applications are usually non-graphical and require you to know a bit about networking and Unix commands.  Only a little is introduced below.
Make sure that your PC is connected to the campus network with TCP/IP running.  Consult technicians to configure TCP/IP in the “Network Neighborhood” properties for Windows.  You also need TCP/IP installed for sending overseas emails, browsing web pages, etc.

Start your Telnet application.  Select “Connect > Remote System” and then input the hostname (better with full domain name).  Click the “Connect” button.  Wait for response from the remote workstation.
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If the connection is correct, you will see something like:

AIX Version 4

(C) Copyrights by IBM and by others 1982, 1994.

login:

Type your username, then password.  After a while, you will see something like:

Sci Computing Lab, HKBU

=======================

Welcome to the Workstation SCCS4 (AIX Version 4.3)!

...

(Last unsuccessful login: Wed Feb 4 11:29:37 1999 on /dev/pts/4 from ...)

Last login: Fri Feb 6 18:05:58 1999 on /dev/pts/3 from ...

guest@sccs4~:1>%
The last line is a command prompt which varies from accounts to accounts.  Here you see the prompt showing the username “guest” and the hostname “sccs4” with a C-shell indicator %.  You type commands at the cursor immediately behind %, say,

% ls

Press Enter to submit the command and you will see a list of files in your home directory.  In the beginning, you should have no file but when you type

% ls –al

You should see a detailed list of hidden files in your home directory.  It reads like magic scripts which are very incomprehensible to newcomers.  Anyway, you have logged in your account successfully!

Notice that Unix commands are all case-sensitive!

Type “exit” to quit the Telnet session.  Always remember to logout after working in a publicly accessible terminal!

2.4 Unix Commands

Follow the steps below to get a first feel with Unix.  Don’t type the prompt character % and remember to press Enter at the last of each line!

To make a “tmp” directory, type:

% mkdir tmp

To go to the “tmp” directory, type:

% cd tmp

Check your current location (which is in the “tmp” directory) by:

% pwd

To create an empty file called “test” in the current “tmp” directory, type:

% touch test

To delete the file “test” (followed by ‘y’ or ‘n’ confirmation), type: 

% rm test

To remove the empty “tmp” directory, type:

% rmdir tmp

To go up one level in your tree directory structure (Unix file system uses tree structures), i.e. go back to the home directory, type:

% cd ..

Notice the space between “cd’ and “..” which is absolutely necessary!

To learn about all details of a command, say, ls , type man followed by the command ls:

% man ls
You will see many pages of syntax instructions about the command.  Don’t try to read all but skim them to get a general idea.

To quit the terminal session, type:

% exit

You can read the “Learn Unix Quickly” web pages to learn more about basic commands at:

http://www.sci.hkbu.edu.hk/

unix_intro.html

3 Linux

This section introduces the Linux operating system.  You are assumed to have basic knowledge of Unix operation.

In Science Faculty, some labs have Linux operating system installed.  Some wonderful features of this system are that it is Unix based, full of useful freeware, strongly implemented with various network protocol support, and it can access other kinds of filesystems like DOS.  You can also install Linux in your PC free of charge due to the great GNU Public License (GPL).  This fast-growing operating system deserves our attention.

3.1
Linux Startup

After booting the machine, you may see a LILO prompt (this is the Linux Loader, some machines will skip the prompt and boot into Linux by default).  Type [Tab] to see what systems are available.  You should see “linux” as a choice.  Type “linux” after the prompt.  Wait for the system kernel loading.

Notice that some Linux workstations (like those in Scientific Computing Lab) do not shutdown.  In this case you should see a login prompt or login window on screen.  For example,

sc31 login:

The above example shows that the PC hostname is called sc31.  Enter your username and password.  The graphical interface of your desktop, based on the architecture of the X Window System, will appear.

Depend on what kinds of Linux distributions you are using, you will see different kinds of desktop environment.  For RedHat Linux 6.x (one of the popular Linux distributions), the default desktop environment is GNOME (GNU Network Object Model Environment) or KDE (K Desktop Environment). The window manager (which defines the looks of the window frames and such) may be Enlightenment, Sawmill, Window Maker, etc.  Also, whenever you open a command-line terminal, the default shell is bash, Bourne Again Shell.  

3.4 Set Display from Remote Host

If your Linux workstation has the X library installed, you can run many X applications from remote Unix machines right before you!

Before you telnet to remote hosts and start their X applications, type the following in the command-line terminal of your local Linux host:

$ xhost + [remote host]

For example, type xhost + sccs4 to prepare to accept X connections from workstation sccs4.

After having telnet to the remote host, type the following to set your display:

$ export DISPLAY=[local host]:0

For example, if you telnet from sc31, type:

$ export DISPLAY=sc31:0

Always remember to exit from your telnet session after finishing your work.  The xhost + command opens a security hole for remote machines to control your workstation.  Do not leave such a terminal untouched for long time.

3.3
Software

Many kinds of Linux software are freeware.  Everyday there are newer packages of software coming up.

In RedHat Linux, most software packages come in RPM format (RedHat Package Manager).  The manuals are usually put in /usr/doc.  Some are HTML documents; some are text or postscript files.  There are also man pages which can be read by using the man command, e.g.

$ man gcc

A. Shell Applications

In RedHat Linux, the following shells are supported:

ash, bash, tcsh

The following shells are replaced as indicated:

bsh ( 
ash

csh ( 
tcsh

sh  ( 
bash

Here is a list of common applications:

text editor
-emacs, pico, vi

word processing
-tex, latex

doc converter
-a2p, ps2ascii, texi2html

programming
-g77, gcc, perl, tcl

mail tools

-elm, mail, pine

More shell applications can be found in /usr/bin while system commands can be found in /bin.

B. X Applications

Please notice that the X display is usually set with 16, 24, or 32 bit colors.  Some X applications may require lower bit colors to run normally.  Contact technicians to configure X display for these special purposes.

Here is a list of useful graphical applications:

web browsing
-netscape
PDF reader
-xpdf
PS reader
-ghostview
Text editor
-gedit
calculator

-xcalc
plotting

-gnuplot, xmgrace

2D graphics
-gimp, gqview, xfig

Some labs may have licensed software like:

mathematics
-matlab, mathematica
You can click the desktop menu to select more graphical applications.  Others can also be found in /usr/local/bin or /usr/X11R6/bin.

3.4
Exit from Linux

Do not shutdown a public Linux workstation in labs.

For your own Linux workstation, do not turn off the power during Linux operation!  Unsafe shutdown may result in file loss or system damage.  The proper way to turn off the machine is to select the “shutdown” option in your desktop.  You will be asked for your password to do so.  Old versions (kernel 2.0.36 or below) require superuser password to shutdown or press [Ctrl + Alt + Delete].

Improper shutdown will make the system run the command fsck (filesystem checking) scanning the hard disk each time you reboot, like Windows ScanDisk.

4 Check Your Mail
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This section introduces two mail tools: Netscape and Pine.  If you have several accounts and want all your mails sent to one account only, read the last section.

You should choose a mail tool which fits your purposes.  Netscape mail is highly recommended because it supports MIME (Multi-various Internet Mail Extensions) efficiently and you will find it easier to handle mails which have many multimedia attachments, like graphics, sound files, plug-in packages, HTML, etc.

The adverse effect is that this kind of mail tool is open to more hazardous Internet mail attacks.

4.4 Using Netscape
Here Communicator 4.x will be introduced.  Contact technicians to set the proxy settings for your browser if you find web-browsing being too slow.  Only the “Messenger” feature will be covered below.

A.
Netscape Communicator 4

In Windows, Communicator supports multi-user services in the same PC.  Before you open Communicator, you should set up your own account with your own preferences in Communicator, to avoid messing others’ preference records.

In Linux, it will automatically set up your own Communicator account.

B.
Communicator(User Profile Manager

For Windows users, open “Programs > Netscape Communicator (whatever edition) > Utilities > User profile manager.”

The “Profile Manager” dialog window will appear.  Click “New.”  Then “Next.”  Then input your full name and email address.  Click “Next.”  Change the “profile name” only if you want.  Then “Next.”

You shall see the “Mail and Discussion Groups Setup” window with three input fields.  Change the “Outgoing mail [SMTP] Server” to the one that you will use to send mail.  One of the campus-wide mail servers is net1.hkbu.edu.hk.  Ask technicians about your specific mail server.  Click “Next.”  Now change the “Incoming Mail Server” (e.g. net1.hkbu.edu.hk).  Select the “Mail Server type.”  Choose “POP3” as most servers support POP3 (you can still change this to “IMAP” later in the preference records if POP3 does not work).  Click “Next.”

Lastly, enter news.hkbu.edu.hk in the field of “News (NNTP) server” if you would also like to read Usenet newsgroups (but we will not discuss them here).  Leave the “Port” number as 119 and “Secure” not clicked.  Click “Finish.”  Communicator will start automatically with your account.

If you close Communicator and open it later, you will be asked which user account you would like to open.  There is no user password security for it, however.

You can always click “< Back” at the bottom of the dialog window to go back to previous pages for checking correct data.

C. Communicator(Mailbox

After starting Communicator, by default you shall see the web page browser.  To open your mailbox, you can select “Communicator > Messenger Mailbox” from the top menu bar.  You can also open it by pressing Ctrl+2 or clicking the “Mailbox” icon in the floating tool bar.
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You will be asked for your password to login your mail account in the remote server.  Then Communicator will automatically check for any new mail in your inbox.

Sometimes mails come with attachment files.  These are indicated by the clipper icons which appear at the upper right of the message bodies.  Attachment files can be shown after the message bodies by selecting “View > View Attachment Inline” if the file format is supported.

If the attachment files are not shown in the message bodies, right-click on the clipper icons and choose “Save Link As…” to save the files in local drives and then open them using proper application programs.

Besides the “Inbox,” you can check other boxes by selecting in the upper-left pull-down menu.  For example, select the “Samples” box:
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You will see how fancy your email can look like.  The samples are HTML documents.

You can create a new box by selecting “File > New Folder…” in the top menu bar.  The “New Folder” dialog box will appear. Input the folder name and make it as a “sub-folder of Local Mail” by selecting the “Local Mail” box in the pull-down menu.  Then click “OK.”

To manage your mails, create boxes with evident names like “My Friends” or “Business” to categorize your mail storage.  You can then move any read mail to one of these boxes by selecting “Message > File Message > (box name)” in the top menu bar.

Simply delete any unwanted mail in inbox by selecting it in the upper frame and then pressing Delete.  Deleted mails are moved to the “Trash” box.  You should clean it occasionally. 

D. Communicator(Address Book

Not only the “Address Book” helps you manage lots of email addresses handily, it also helps you to set personal email aliases without consulting mail server administrators.

Select “Communicator > Address Book” in the top menu bar or type Ctrl+Shift+2 to open the address book.

By default, your “Personal Address Book” is open.   Click the “New Card” button in the tool bar to enter the address information of one person.  Click the “New List” button and enter existing persons’ names one by one to group them into a list.  A name list is useful for sending emails to the same group of persons frequently.  It just works like an email alias.
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Double click on one of the email addresses in the lower frame to open the card contents for editing.

You can search for the information of a person by entering her name in the upper left entry field.

E. Communicator(Sending Emails
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In the mailbox window, click the “New Msg” button in the tool bar to compose a new mail.  Similarly, click “Reply” or “Forward” to answer an email highlighted in the upper frame.

The “Message Composition” window appears.  Enter the field of “To:” email address or click on the “To:” button to select other mailing like “Cc:”  You can also input addresses by clicking the “Address” button in the tool bar, which opens a ‘Select Addresses” window.  You can then highlight any address and click its corresponding mailing button (To:, Cc:, etc.) or highlight a name list previously made in the address book for group mailing.  Selected addresses will appear in the lower frame.  Click “OK” to set them to the address fields in the “Message Composition” window.

For privacy concern, one useful sending method is BCC: (Blind Carbon Copy).  It is similar to CC: except that all BCC: recipients will not be able to see the names and addresses of other BCC: recipients in the received mail headers.  
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Besides typing messages in the mail body composition frame, you can attach any MIME file like “MS Word” document by selecting the second tab which looks like a paper clip and is right above the 

“Subject” field and below the “To:” tab.  Simply click on the empty space of the attachment tab, then a window will pop up for you to “enter a file to attach.”

Do not attach very big files like files over 5MB.  Make sure the recipient’s mail inbox in the server side has enough space.

The third tab includes security options like encryption, signed messages, etc.  Refer to “Help” for further details.

Click the “Send” button to confirm sending your mail.

F.
Communicator(Preferences
You can control your mailbox features even better by setting the Communicator preferences.  Select “Edit > Preferences…” to open the “Preferences” dialog window.
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Choose “Mail & Groups” in the left tree menu.  Here you can set the display features.  Open the subdirectories under “Mail & Groups” in the left tree menu and select “Identity.”  Here you can attach a “Signature File”  (a few lines of your contact information or motto; keep it small) to every end of your composed mail.

Select “Mail Server” in the left tree menu and you can set your “Mail Server Type” and decide if you would like to keep mails still on server after retrieval.  (Do so only if you need to retrieve the same mails from other computers; this option will make your mailbox in the remote server explode sooner or later!)  Further click on the “More Options” button at the lower right corner.  Here you can set the period for Communicator to check for any new mail (of course you need to open Communicator all the time).  You can also set Communicator to remember your password after the first input for future convenience.
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4.2
Using Pine
Pine is a common mail tool originated in Unix systems.  It is non-graphical but easy to use(especially that users do not need to set any mail server setting (but some client settings are needed) before sending mails.

3.2.1 Starting Pine
Login a Unix workstation from an X-Terminal or by telnet.

At the Unix command prompt, type:

% pine

You shall see:

Type “c” to send a message, “i” to check your incoming mails, “l” to manage your mail folders, etc.   Type “?” to read the help manual if you are new to Pine.

You can also set the signature file, printer, account password, and other configurations by typing “s.”  The address book helps you setting aliases for group mailing.

Again, to save space in your inbox, you should configure your Pine setup by pressing “s” then “c” and then insert a folder name for the field “read-message-folder.”  Press “e” to exit setup and confirm with “y” to save your configuration.  In this way, you will be asked to move read mails from inbox to the folder that you have set, which is under your home account, with more space.

4.3
Other Mail Tools

Other graphical mail tools like Microsoft Windows Outlook Express, Lotus CCMail, Eudora will not be covered here.

There is an old text-based mail command in Unix which enables users to check and reply mails quickly.  Simply type mail in the command prompt to check incoming mails.  Type ? for help.  Type d1-8 to delete mail 1 to 8, so on.  Type q to quit.  To send a mail, type mail (email address) at the command prompt to compose a mail and then type Ctrl+D at the end of the message to send the mail.  Notice, this mailer does not support MIME file types.

4.4 Getting Mails from Several Accounts

Instead of setting various complex configurations in your mail tool or checking different mail accounts repetitively, you can receive mails from several Unix accounts through connection with one account only.

The method is to forward all mails sent to your remote Unix accounts further to one of your frequently checked account.  Then you only need to check this one without bothering with all others.

We will learn a simple way to forward mails below.  We assume the mail servers are Unix-based and using sendmail 8.8 or up.

Simply put a hidden file named .forward in each home directory of your remote Unix accounts (except the one from which you are going to directly get mails).  This file must contain the target email address (supposed to be your frequently checked account).  It is suggested to be the nearest account from your working place.

You are assumed to know how to edit a text file in Unix system like using vi, emacs, etc.  Simply write the target email address in all .forward files, then save them in the home directories respectively.  For example, write the following line with your username in all .forward files:

(username)@hkbu.edu.hk

Then all mails will be forwarded to the campus mail server.  Never make any two-way forwarding! Mail loops will flood your mail box and may deny all mail services!

Remember to edit or remove the .forward files if later you change your working place!

4.5
Mail Security
Due to recent attacks or virus intrusion through Internet mails, users should concern about mail security problems.

Report any mail bombing at once.  If your inbox is over-flooding, it’s sometimes useless to clean it no matter how hard you try.  The source of flooding must be stopped.  Contact technicians and keep at least one mail for tracing afterwards.  Notice: intentional mail bombing is a crime.

Do not open any suspicious attachment file which may carry lethal viruses. Scan it with virus scan software with latest virus data if you must open such file.  Notice: intentional virus distributing is a crime.

For a publicly accessible PC, do not save your mail account password in any mail tool.  Other users might be able to retrieve your password in such an openly used PC.

5 Start Working in PC or Unix

This section explains miscellaneous topics to enhance your working environment.  It involves technical details for which you should consult technicians in case of doubt.  Always prepare a safe way to go back to the original configurations if you intend to change the current ones.

5.4 Install Software in Your PC

Licensed software provided on campus should be installed by technicians.  If you are going to remove any university licensed software in your PC, you should inform technicians to keep track of the records before you do so.

The operating system is always licensed (Linux under GPL).  Do not remove or upgrade it yourself.

A. Licensed Software Personally Bought

Occasionally, users may buy and install their own licensed software in their PC’s on campus.  Most Windows programs are easy to install but those of DOS or other operating systems are not necessarily evident.  Anyway, always keep the following in mind:

a. check the software documents of system requirements like operating system version, CPU speed, RAM, hard disk space, peripherals, network protocols, etc., before you install any software;

b. input your personal information and any serial  number correctly if necessary;

c. after installing, fill in the registration form and mail it if you want further supports from the software companies; university technicians might not be able to support software personally added;

d. new software usually has bugs; go to the corresponding websites mentioned in the manuals to download the latest patches;

e. in Windows, always uninstall software by the uninstalling program provided by the software itself; if it is not there, open the “Settings > Control Panel” window and then click on the “Add/Remove Programs” icon to uninstall the software; if also not there, it is highly possible that the software is not a Win9x application (perhaps Win3.1 or DOS) and you should read the software documents to uninstall it properly(which might involve editing the files of config.sys, autoexec.bat, etc.); some users might find that some general uninstalling utilities are handy for cleaning up their PC’s, but please be familiarize with the pros and cons of the utilities(none of them are perfect;

f. quickly inform technicians if system damages occur after installing new software; you are responsible for your own data loss in such cases.

B. Shareware, Freeware, Beta-testing Software

It is often good to test a new piece of software before you buy it.  This option is often provided by software developers on websites, free CDROMs, or mail delivery packages.  In general, there are three kinds of software testing options which are explained below.

Shareware is the most common.  It is not free.  Often it is only partially working.  You need to register and pay for the fully-functioning licensed versions after trials. Freeware is free but some still requires you to register.  Beta-testing software is released to expert users for them to test with and report any related bugs for further improvement.  It is usually free and needs registration or removal after testing.  Read the license documents for legal issues.

You can search for shareware in:

http://www.shareware.com
http://www.download.com
Choose Hong Kong sites for fast downloads like:

ftp://ftp.ust.hk
ftp://ftp.comp.hkbu.edu.hk
5.5 Printing

For new PC’s, ask technicians to install printer drivers and network print queues.

Print hard copies only if necessary.  The less you print, the more technical you are.

A. Printing Preparation

Before printing a document, always check “File > Print Preview” first.  Edit mistakes and check it again.  (Well, it is easier to check in hard copies but try to keep these few.)

Next, check your “File > Page Setup” of important details like paper size and paper orientation to reduce printing errors.

Select “File > Print” or press Ctrl+P in most Win95 applications to print the document.  A “Print” window will appear.  Before pressing “OK,” always make sure that the printer profile and its properties are correct!

What is shown on screen may not be printed correctly on paper.  There are lots of possibilities causing this like:

a. wrong printer drivers, postscript levels;

b. wrong page setup;

c. wrong printing resolution (in dpi, dots per inch);

d. printer fonts not installed;

e. document formats not correctly converted;

f. documents protected by security utilities;

g. wrong data linking or object embedding in documents;

h. typing hidden characters;

i. macro viruses in documents;

j. printer spool folders full or files corrupted;

k. network transmission errors;

l. printer toner out;

m. wrong color calibration in printers;

n. bad paper quality;

o. damaged printers

B. Monitor Your Print Jobs

Monitor your print jobs by clicking the printer icon which appears at the lower right corner of the application window during printing.  You can also do so by clicking the printer icons in “Settings > Printers” menu.  A printer status window will appear.  Stop your print jobs by selecting “Printer > Purge Print Jobs” in the printer status window.
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C. Print in Unix System

Check the available print queues by the lpq command (command options differ from platforms to platforms) or by any graphical system management utilities in your workstations.

Print files by the command

% lpr –P (print queue) (file name)

Monitor print jobs by

% lpq

Notice the job numbers.  Remove jobs by

% lprm –P (print queue) – (job number)

Make sure your print queue is a postscript queue, not an ascii queue, if you print postscript files.  Kill print jobs by commands or in printer control panel immediately if you make any mistake.

5.6 Transfer Files Remotely

Besides emails, you can transfer files to and from remote locations more actively by FTP (File Transfer Protocols).

Distinguish between public FTP sites and private servers.  For public FTP sites, you can login by Netscape anonymously (automatically done with “anonymous” as username and your email address as password); for example, type the following in the browser location field and go to the HKUST public FTP site:

ftp://ftp.ust.hk/
For private servers (which has not set up public FTP services) in which you have accounts, you need to use an FTP application program to login them with your username and password.

A good Windows FTP shareware is WS_FTP.  Besides usual Internet transfer, it supports proxy settings which enables users to transfer files to and from an Intranet through a firewall proxy server.  Refer to its packages for instructions.

Like Telnet, a common text-based FTP program comes with Windows system.  It is located under the \windows directory.  Type ftp in MSDOS prompt to invoke the program.

A. Some FTP commands

You are assumed to know some basic DOS and Unix commands (e.g. cd change directory) to use a text-based FTP program.

To login a server, type the following after the ftp> prompt:

open (server domain name)

Wait for connection.  Then input your username and password.  If you type incorrectly, enter user in the prompt to retype your username and then password.

If successfully login, you shall see something like:

Remember, DOS is case insensitive but Unix is case sensitive!  Also, DOS uses \ for directory levels but Unix uses / instead!

Type ? for a help list.  Type ? (command) to read command instructions.

Type lcd (pathname) to go to the proper local drive and directory of your PC. 

Type pwd to check the current path of remote server.  Then type cd (pathname) to go to the desired location in remote server for file transfer.

Type binary to prepare to transfer files in binary mode.  (The default is ascii mode used only for text files; ascii data conversion among different operating systems often mismatches and non-plaintext files will be corrupted if transferred in ascii mode.)

Type ls to list files in remote Unix directory.

Type put (filename) to upload a file; get (filename) to download a file.

Type mput (filenames with wildcards) to upload multiple files; mget (filenames with wildcards) to download multiple files.  For example, type mput *.gif to put all GIF image files to the remote directory.

Type close to end an FTP session. Type open again for another session; quit to close the program.

Remember, FTP session counts login time!  If you are idle for long time, the session will be closed automatically.
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N.B. Most italic terms in this manual are registered trademarks.  You are free to make copies of this manual unaltered and distribute them without profit-making within HKBU campus only.  You can also download this document from

http://www.sci.hkbu.edu.hk/doc/SCIPC.pdf
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